[MAC] Game doesn't load correctly on Sierra

edited July 2017 in Bug Reports
CS freezes after start before even reaching menu (macOS Sierra, Humblebundle, but Steam is installed).

CS launcher starts but when clicking on "Play" the program window closes and nothing happens.
There is a workaround to right click on CS-launcher - click on "show package contents" - open "contents" - open "macOS" and starting castlestory-launcher from there.

Afterwards it is possible to start CS but only Steam workshop maps are offered,
Again there is a workaround to right click on CS - click on "show package contents" - open "contents" - open "macOS" and starting castlestory from there. Now all maps are offered.


  • What's your computer specs? The lack of maps offered sounds similar to another issue where only Quasar is shown. The solution was that the PC was too weak to handle Castle Story and was unsupported.
    Additionally, have you tried a fresh reinstall? I'm assuming you have.
  • Hi Dr,
    I tried a fresh install without success. My Mac has 16 GB Ram, Core i5 and 125 GB free space on SDD - should be enough. And with my workaround I can see 13 maps ...
  • So wait, are you running it through steam, and it's not working when you click play through steam? I'm a bit confused on what your workaround is doing. (I don't use Macs)
  • I'm running the DRM free version but Steam is installed.
  • Just uninstalled Steam completely and made a clean install of CS. Still same problem. Can anybody confirm that CS runs on Sierra without issues? Maybe it's a problem of the new introduced path randomisation in Sierra.
  • edited July 2017
    On MacOS most of the programs don't have an installation wizard. They appear as a file with the extension app and you just have to drag'n drop them to application folder (which is very comfortable especially in case you have to uninstall it later).
    In reality this app file is a package which contains all files and folders of the app and you can view them by right clicking and click on "show package contents". In rare cases the package is defective (or not made for the target platform) and then it makes sense to try to start the program from package content.
  • EvaxMeorEvaxMeor Administrator Developer
    Hey there,

    I'm trying on our MAC Sierra 10.12.5 the build 0.9.2a MAC 64 bit and it's working fine when I start from the castlestory-launcher.app and from Castle Story.app .

    But I start the game in Windowed mode first, so maybe it's that, you don't see the Icon of Castle story at the bottom right? If I switch back to fullscreen, it's still working.

    Maybe you could send us the logs, follow this link to help you find them on your mac: https://sauropodstudio.zendesk.com/hc/en-us/articles/115001840547-How-to-Find-Multiplayer-Logs .

    Sorry for the inconvenience.

    Thanks for the report and support!
  • Hi EvaxMeor,

    sorry for late answer. Windowed mode doesn't solve the problem. I sent the log you requested.
  • Hi,

    with version 1.0 I still have the same problem...
  • EvaxMeorEvaxMeor Administrator Developer
    edited August 2017
    I'm curious, if you place the folder of the game on your desktop and you start the game from there, does it work?

    Are you starting the game with an alias?
  • There are still no maps when I start from desktop. I don't use an alias.
  • What are your computer's specs? Could you post a screenshot of the information that Speccy gives you?
  • Hi DrWhoCares,

    can not install/run Windows Software on my Mac (MacBook Pro (Retina, 13-inch, Late 2013), current MacOS, fresh install end of April).
    CS shows all maps using the workaround thus I guess it's not a problem of insufficient system specs.
  • My apologies, I assumed that wasn't a direct download link, and that they had a Mac version (they do for CCleaner).
    If needed in future you could use one of these.

    I remember a few posts where the issue was the specs of the computer, as there is a setting in the Options menu that says "Unsupported Game Modes" which I believe is hiding these maps from you.

    Castle Story requires a 64bit OS, because it requires more than 4GB of RAM. On top of that, it requires a decent to good CPU to run, and a very good CPU to run well, even in the later stages of the game. Due to the new graphics, there is also a slightly increased requirement for GPU, as some people are now reporting that they are getting lag, which is likely due to their GPU bottleneck.

    However, all in all, this may not be your issue, as I don't know much about Macs, nor their build for OSX, but your issue seemed incredibly similar to ones in the past.
  • As already mentioned: 16 GB Ram, Core i5 ... should be OK.

    Good point with "Unsupported Game Modes". Starting CS the "normal" way doesn't allow to save this setting. When I start with workaround I can save the checkmark for "Unsupported Game Modes". However when starting the game again the "normal" way the checkmark is not visible (of course here the maps are not visible as well).

    Starting the app the "normal" way somehow prevents the app from finding it's additional resources like maps and settings.
  • Ah yes, I see I had forgotten you already posted those specs long ago.
    Well, once again, likely it is something wrong with Mac Sierra, or something else entirely.
    As I am not a developer, I can likely help you no further :C
  • EvaxMeorEvaxMeor Administrator Developer
    edited August 2017
    Thanks for the logs, right now we found that the bug is caused by AppTranslocation (new feature on Sierra)

    We are investigating
  • edited August 2017
    I'm just curious. Is AppTranslocation somehow connected to or the same like path randomisation I mentioned before? BTW it's a really nice game!
  • EvaxMeorEvaxMeor Administrator Developer
    edited August 2017
    It is indeed and thanks for the feedback! :smiley:
  • Hello,

    I waited now 4 months and tried again with version 1.1.0.c4 and still have the same problem.

    Found this "solution" in another thread:
    1- If you're on a Mac and you downloaded the game from Humble Bundle, you may have only moved out Castle Story.app from the compressed file. That won't work, you need to move all the files and keep them all together in the same format they're in the compressed file.

    I never moved the app alone in another folder. And it doesn't matter if I move the complete folder or leave it where I unzipped it. There are never maps when starting the app from this folder!

    You probably should make one app which contains everything (which would be more Apple like).
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey @casteldefender123 - it's difficult to troubleshoot this issue because it's really uncommon.

    If you'd like to, we can schedule a remote assistance session where I'll be able to see your screen and click for you - in order to see for myself and try to understand what's going on.

    If you're interested in that, please open a support ticket on http://support.castlestory.net with your availability.
Sign In or Register to comment.