No maps under new game - Mac - Humble Bundle

I'm playing on a Mac with the humble bundle download, and when I click on "new game" there are no maps available. I searched "Castle Story" on my computer and deleted every file, then re-downloaded and reinstalled the game, and still no maps. Help!


  • mtutormtutor Member
    I did an independent download on another Mac that has never had Castle Story on it and had the same issue.
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey mtutor,

    What are the specs of the two machines you've tried playing on?

    If you go in your Castle Story/info/maps folder - do you see anything?
  • mtutormtutor Member
    edited July 2017
    On both machines, I see a bunch of folders, BigIsland, Colibri, etc.

    The first computer is a Mac Mini that is two years old, and I have played 0.5-0.8 on this machine:

    • 2.6GHz Dual-Core Intel Core i5 (Turbo Boost up to 3.1GHz)
    • 8GB 1600MHz LPDDR3 SDRAM
    • 1TB Serial ATA Drive @ 5400 rpm
    • Intel Iris Graphics

    The second is a Mac Air that is one year old:

    • 1.6 GHz Intel Core i5
    • 8 GB 1600 MHz DDR3
    • 128 GB SSD
    • Intel HD Graphics 6000 1536 MB
  • mtutormtutor Member
    On both machines, maps are available and working if I don't open castle story through the app or the launcher, but if right-click the app and show package contents, and then I open the game via Contents/MacOS/Castle Story...
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    I'm going to forward this to our QA, mtutor.

    Sorry about the inconvenience.
  • EvaxMeorEvaxMeor Administrator Developer
    Hey mtutor,

    Sorry for the inconvenience, but if you can send us the logs, it will help us a lot! (Repro the bug first) :D Here a link to help you find them: .

    Thanks for report and support!
  • mtutormtutor Member
    Here you go. Hope this helps!
  • Hi mtutor,

    I have the same issue (unfortunately I didn't notice your entry in troubleshooting section and added one to bug section).
    Are you running Sierra? I'm not sure if the problem is related to Sierra because I upgraded to Sierra and started to use CS 0.9x at the same time.
  • mtutormtutor Member
    I am. I think I had installed 0.8 before updating to Sierra, and I could play it even after the update to Sierra, which makes me think it might be a combination of 0.9 and Sierra.

    Hope this helps! Did you see the workaround in my second post from July 12th?
  • Hi mtutor, thanks, yes the workaround works for me too.
Sign In or Register to comment.