Loading levels stuck at 90%

Hi there. I'm playing this game on a macbook pro (Processor: 2.8 GHz Intel Core i5, Memory: 8GB 1600 MHz DDR3, GraphicsL Intel Iris 1536 MB) and I can't seem to get any levels to load.

I can use the level editor just fine, but when I try to load a level in sandbox or invasion the loading screen slows to a halt at "entering world." Each level will stop at a different point, one even stopped at 100%. The yellow loading symbol still animates (slowly) but the game stops responding and will never proceed. I've been able to play this game on this computer before with no issues. (It's been maybe a year or two since I've played)

Here is what I've already tried:

- Reinstalling the game
- Reinstalling the game AFTER deleting the info folder, along with any castle story file on my computer
- Changing the aspect ratio and lowering graphic quality
- Double checked to make sure my laptop was plugged in and not running on any battery saver mode
- Closed all other programs on my laptop to conserve memory

So far, none of these have worked.


  • Hey Corky
    Your CPU shouldn't be the problem from what i see you have a MacBook Pro from mid 2014. But just to make sure how high is the load on your CPU while trying to load a map ?
    Try loading the map troubled Heaps and Pioneer Pass.
    How long are you waiting before you give up.

    My suspision is that your macbook isn't enough anymore. A lot has changed in the past 2 years
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey Corky,

    Which Intel Iris do you have? Your CPU and RAM should be OK, but it could be your graphics card.

    You said you've tried a fresh reinstall in your second bullet point there, right? The last person to report a similar issue fresh reinstalled and it worked fine afterwards. You uninstalled on Steam, then deleted the "Castle Story" folder that remains in your steamapps/common directory after uninstalling, then reinstalled, correct?

    Could you also make the crash happen, then provide me your logs? https://sauropodstudio.zendesk.com/hc/en-us/articles/218907727-How-to-recover-game-logs
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey Corky, I saw that you opened a support ticket as well, so I'm going to continue our conversation there.
This discussion has been closed.