Click to remove one

It says "Click to queue 1" but it would remove it so shouldn't it be something like "Click to remove" aslo on a side note i would write 1 out. You know you are supposed to do that from one to twelve. It would look better that way and it's space for it so why not :D


Sign In or Register to comment.