Mineshafts and Quarrys aren't working anymore

Hello everybody
I updated one of my Castle Story saves after the update. At first my Bricktrons were able to use everything just right and then after an hour or so they decided not to work anymore. The mineshafts and quarrys are connected to the stockpiles and they are able to move everywhere. But they dont want to work.

If you need anything like a save file just tell me.


  • Hey Creaperbox

    I just helped someone in the Discord with a similar problem and the solution was to verify the integrity of the game files.
  • @Matthew7991 Alright I was finally able to test it. And it didnt work not even if I used a new world. Can you help me again? Or @Shatojon can you help me?
  • Well do quarries work in other saves/new worlds ?
    Do new Quarries and Tunnel Tasks work or are just the excisting ones broken.
    I could only think of a fresh reinstall

    And if it's actually just the one save Shatojon would need that save to help you
  • @Matthew7991 no its everysave new and old worlds.
  • Yea then it's defently not the save. Try to do a fresh reinstall and then verify the integrity of the game files. It worked for the other dude i helped.
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Thanks for reporting this, I've forwarded it to our QA.
  • SamhainSamhain Administrator
    Hey creaperbox, still not working? Here's a couple things you could do to help us find the problem. Check your stockpile exclusions and the resource toggles on the tunnel and quarry, try different settings and tell us if it changes anything. It would also help if you could send us a save with the bug, and tell us how you reproduce it. Does the bug always happen after an hour or so, or does it happen right away?
  • @Samhain it Just happened on Monday 26.06.2018 and I dont know why. I just entered the world and then they stopped working an anything. I tried to look if their way is blocked or the Stockpiles are full, but everything was alright.
  • Mhhh interresting Doesn't seem to work for me either. But it defently seems to be a bug. The workaround for me was to set 1 Stockpile to accept any and it works. But i couldn't reproduce the bug in a other world.
  • dammit
  • SamhainSamhain Administrator
    Yep, I just tested your save, and I can confirm that I have the bug, and as Matthew said, you can set 1 stockpile to accept anything as a workaround and bricktrons will work. I agree that they should anyway since the tunnel toggles for iron and brimstone were off. Your tunnel and stockpile setup seems to cause a corner case bug in the AI. I'll try to investigate this when I can, I hope Matthew's work around works for you in the meantime. Can you confirm if it works or not?

    Nice statue by the way, this is a great entry for the event, I hope you can finish it in time. I'll see if Shatojon can't give you a small extension to finish it.
Sign In or Register to comment.