Loading stuck on Initializing Scripts

As the title says, my game is stuck on Initializing Scripts when ever I try to start a map.

The yellow arrows stop spinning, and if I click anywhere the game crashes and must be closed through the task manager.

Great update, but I'd love to play it.


  • I have the same issue, but I also had this with the 0.5 version. Before that it used to run fine. I'm running win8 on my game rig. Will try it on a different system when I get the chance.
  • Same issue, Windows 10 though. Wont get past initializing scripts.
  • Found a workaround on Steam forums that works.

    "This is a problem when "Terrain Acceleration" is set to "Only when loading" or "Always." Change this to "Never" and you're all set. This option can be found in the Graphics submenu in the Options when you are in the main menu."
  • EvaxMeorEvaxMeor Administrator Developer
    Hey there,

    Sorry for the inconvenience, it is like that for every single map? Yes, setting Terrain Acceleration to never, can help indeed.

    You guys tried to not click anywhere when it's loading? I know on Windows 10, it will tell you the game is not responding and it will forcing you to quit the game, but it should not happen if you don't click anywhere, just let it load.

    Hope it helps!

    Thanks for the support!
  • I can't test setting Terrain Acceleration to never right now, but I'll give it a go when I get home.

    It only happened for me when I tried the invasion or conquest modes, not when I tried creative mode.

    Also, I clicked the screen when loading creative mode and it looked like it stopped responding, but then it recovered and loaded the map. So I don't think clicking the screen directly caused the crash. I tried waiting while loading conquest, and it was stuck for at least 5 minutes before I clicked.

    Thanks for the help.
  • EvaxMeorEvaxMeor Administrator Developer
    Thanks for responding!

    Umm, what are the specs of your computer?
  • Acer Aspire laptop, i3-4010U processor (1.7 GHz, 3MB L3 cache), Intel HD Graphics 4400, 1792 mb dynamic video memory, 8gb ddr3 ram. Hope this helps.
  • EvaxMeorEvaxMeor Administrator Developer
    Yeah, when you got the time, you should try the Terrain Acceleration to Never and it should help.

    Thanks to let us know
  • I'm on a laptop as well & had about the same issue.
    Running without Steam solved it all for me (thx Forgetaboutme) :)
  • Setting Terrain Acceleration to never did the trick. Thanks for the help.
  • EvaxMeorEvaxMeor Administrator Developer
  • Nice!!
  • Disabling Terrain Acceleration worked like a charm. It looks like this is a laptop issue. I too had this issue with a laptop. I tried it on a desktop and it runs it fine with Terrain Acceleration on. Both have dedicated video cards. If you need help debugging this issue I'm more than happy to help.
Sign In or Register to comment.