After update 1.0 my SAVE crash


I have problem with my save. I had there rly big construction, and i don't wan't to lose it.
Ok i almost figure out what is wrong, but i will tell the short story.

So when yesterday game was on new update, on my LOAD GAME list it was button "UPDATE" instead of "PLAY", i click this, and after this, i allways getting red msg ERROR at 88% of loading.

I have good computer, i play at this game almost 2-3 years, also i reinstall the game and nothing helps.
Then i create another map, build some 2-3 bricks, and save like "A". And i replace files from my old SAVE. And i figure out, that the game crash only when i copy this file: PlacedBlocks.json.
Can someone helps me with FIX this issue? I don't want to lose my SAVE becouse of update... :neutral:


  • P.S. Yes i have ver 1.0A HOTFIX
  • So the Update button is for updating a save prior to v1.0 to 1.0.
    When it does this, it should create a backup of your save. So you shouldn't have lost it.
    I do not know how to fix this issue, because I have never seen it, but there's the information I do know.
  • Yes it already update the save, i see the PLAY button, and save loading, but after 88% it crash. I see red bar, and the save freeze... And I have this save, so no problem with that, but there is a problem with file: PlacedBlocks.json.

    There is some FIX program for save, or can I edit somehow the PlacedBlocks.json myself? Myebey there is some code that crash at 1.0ver?
  • What version is the save coming from? Does Castle Story create a crash log that you could upload here? Could you also upload the save, the one that has not been converted?
  • Unfortunately i don't have this save what is not converted...
    SAVE is directly before 1.0 I play one day before...

  • I took pic of the error. Also i go into a maps folder and change this file Placed Bloks, and try to start new game with this blocks already build there, but even when i want start new game on this map, there is this mistake, so after the update there is some mistake on this one file.

    When i replace all other files like plant / iron etc, even how many workers and their position before SAVING everything works, but not this placed blocks... And then i have all my resources and workers, but not the CONSTRUCTION what is the most important...
    12.png 22.9K
  • There should be a backup of the save located in "Castle Story > Info > Backups"
  • faviannfaviann Administrator
    If it still doesn't work, it would be great if you would create a support request and sending your backup save at the same time.
  • With Backup it will be problem i didin't know there is backup, and for 99% its gone, bec like i wrote at my 1 post i arleady reainstall the game :(

    And i already make the support request and i get answer, that the problem will be solved on this forum... YHY :neutral:
  • I send via mail, and also here i put my SAVE
    1.rar 2.8M
  • EvaxMeorEvaxMeor Administrator Developer
    We got a fixed incoming for that bug! Thanks for the report and thanks to share your save, it's really nice all the rope bridge everywhere!
  • EvaxMeor said:

    We got a fixed incoming for that bug! Thanks for the report and thanks to share your save, it's really nice all the rope bridge everywhere!

    Thanks ExavMeor - waiting for it so much! Didin't play Castle since 1.0. I'm happy that You like my bridges, and if You saw it, then it works for surre :)
    I will send You fully build of it. :)
Sign In or Register to comment.