Multiplayer saves not loading correctly

I recently encountered a problem when trying to play saves I had made with a friend. Every time we tried to load the save, for me it would show him downloading fine until it was done, for him on the other hand it barely moved and even when it did sometimes it went backwards, meaning it never finished downloading the save.

So I later sent him the save and had him install it manually, which worked until we started loading. He would quickly say that his said "Waiting for host" at 70% while mine was chugging along normally. Then i'd finally get to 100% saying "Waiting for other players" and his still saying "Waiting for host", until he was disconnected saying multiplayer error and loaded into the game by myself.

I really hope the detailed report helps and its fixed because we used to be able to continue our saves normally, but not anymore.


  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey boospacemarine,

    I'm going to forward your bug report to our QA. Thank you!
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey @boospacemarine,

    Could you please attach your save in a reply here?

    Also, had it been a long time since you saved that game and tried loading it again? Sometimes, from one update to another, the game no longer supports older save files.
  • No, we loaded the save the day after we played.

    Here's the save though, it should be called "The war effort"
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hi boospacemarine,

    I successfully loaded your save file, however I notice there are spots only for two players on there, yet you describe three players in your post.

    Are you sure you're loading the game with the same configuration as you started it? The teams/colors/number of players have to be the same.

    Additionally, are you sure everyone is on the most up to date version of Castle Story?
  • No, it was me and one other friend, sorry if I described it like there was three people.
    Yes we did try to start the save the same way we originally started it (team, color, etc.) and we're on the same version.
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey @boospacemarine - that's odd. If you try a brand new game and save/load it, does that work?

    As in, start a new Conquest co-op game, you go both go Team A, you go blue and he goes red, as soon as you load into the game, save it, end it, then load it again and you both go into team A again with you blue and he red.

    Does it work then, or is loading multiplayer games broken altogether for you them right now?
Sign In or Register to comment.