[SOLVED] [Linux] missing textures

rprinsenrprinsen Member
edited June 28 in Bug Reports
Hey all,

Just installed 0.9 on my Ubuntu system.
Game is running quite well performance wise. However I do have some graphical issues (see screenshot).
The bricktrons, wood-like items, the furnace and menu items seem to be missing textures.


My specs:
Intel® Core™ i7-6700HQ CPU @ 2.60GHz
GeForce GTX 960M
Nvidia driver version: 375.66
16G RAM

Anyone having similar issues?

Thanks!
Rienk


Update:
Actually solved this issue! Apparently S3 Texture Compression (S3TC) wasn't enabled on my system. Which results in compressed textures not being able to render.

To check if S3TC is enabled, run the following command:
glxinfo | grep GL_EXT_texture_compression_s3tc

it should return something like this:
GL_EXT_texture_compression_s3tc, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,

To enable it, install the libtxc-dxtn-s2tc package:
sudo apt-get install libtxc-dxtn-s2tc

Comments

  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey rprinsen,

    I've forwarded this to our QA team - missing textures issues are common with Linux users.
  • rprinsenrprinsen Member
    Thanks Shatojon, hope you guys can figure something out. Can remember having similar issues with Cities: Skylines (also Unity right?).
    Really like the 0.9 update, can't wait to play it with all bells and whistles working :)
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Thank you for the kind words, you're awesome.
Sign In or Register to comment.