Game crashing on start

I wanted to try out the new update however whenever I try and start the game it keeps crashing immediately. I can open up the launcher where you can select your resolution however as soon as I hit play it crashes. I've tried doing a fresh install 3 times just to make sure it was getting deleted correctly however that did not help. Any help you guys can provide would be greatly appreciated!

Comments

  • ShatojonShatojon Administrator Developer Backer
    Hey britton,

    Sorry for the late reply, I was asking around the studio to get you a concise answer.

    The game is crashing when the time comes to render the graphics.

    - What are your PC specs?
    - Are your graphics card drivers up to date?
    - Can you try closing *all* software and launch nothing but Steam and the game?
    - It also seems like you're trying to launch the game in 6400x2160 resolution, do you have a very unique monitors setup?

    Let me know! Thank you.
  • thesirbrittonthesirbritton Member Backer
    edited June 15
    Shatojon,

    Thanks for the reply. I've got an i7-7700k, gtx 1080, 32GB of ram and am running windows 10 pro. I've made sure that both windows and my video drivers are up to date as well. I do have 2 monitors, one is 4k and the other is a 1440p monitor. I usually just run games off the 4k monitor though, I never try running them across both monitors. I also tried closing out of all other applications besides steam and tried out all of the available resolution options in the launcher and am still getting the same crash.
  • ShatojonShatojon Administrator Developer Backer
    Just for the sake of troubleshooting, can you please disable all but one monitor and run the game?

    Try each of the monitors, if you can. If that doesn't seem to help, also try in windowed mode. Last but not least, try running the game directly from Castle Story.exe instead of launching with the launcher.
  • Unfortunately no luck. I tried each monitor individually, with full-screen enabled, disabled, as well as launching directly from the castlestory.exe file and they all gave me the same issue.
  • ShatojonShatojon Administrator Developer Backer
    Hey thesirbritton!

    I might have found the solution to your issue. Please close *all* running software besides whatever you need to run Castle Story (aka Steam). I really mean all, if possible. Anti viruses, MSI Afterburner if you have that running, Dropbox, Google Drive, etc.

    Here's a quote from a user that had the exact same issue you're describing; "TLDR Rivastatistics tuner is bad ... comes with msi afeterburner but can be turned off... good luck and stuffs and thanks a TON for the help and time"

    Let me know if that helps.
  • thesirbrittonthesirbritton Member Backer
    edited June 20
    That did the trick! Looks like the issue for me was also Rivatuner. It looks like I was running a few versions behind on it and after updating to the most recent version castle story started right up without any issues. Thank you very much for all the help!

    edit: So looks like that didn't completely fix the issue. It loads up but as soon as I enter the options it crashes again. What does seem to be working is opening the settings of rivatuner and setting the 'application detection level' down to none. After making that change I haven't had it crash on me again. So in the end the easiest solution is likely to just uninstall rivatuner, especially since MSI Afterburner doesn't need rivatuner to function.
Sign In or Register to comment.