Multiplayer Not Working

BenjenBenjen Member
edited February 12 in Multiplayer
So I've been trying to set up multiplayer games with my girlfriend for weeks, and with my cousin for a couple days now, though a few different methods.

When my girlfriend and I played with port forwarding on different wifi systems, she kept getting kicked to the main menu - I was hosting because she was on wifi she had no control over and couldn't port forward. We just blamed her internet strength and moved on.
Last week, however, she came over and we tried to run a local game. This time we tried both players as hosts, but no matter what we came up with this error:



I did a fresh reinstall of Castle Story per Shatojon's instructions, but nothing changed. I did not have time to do a fresh reinstall and try again on her computer.

This weekend I tried the same - local server - thing with my cousin, this time using two of my laptops and running steam offline (he's a console gamer and I'm slowly converting him). Every. Single. Time. I. Tried, I got the same error from above. I did a fresh reinstall of the game on both computers, tried different wifi networks, tried using my phone's hotspot, and tried both computers hosting. No matter what, the game either didn't show up in the join section, or got that bug as soon as the map had finished downloading and the host hit 'Start game'.

Can anyone help me solve this problem or have a solution already? I make multiplayer maps for fun because I really love the idea and engine behind this game and I'd like nothing more than to be able to play with other people.

Incidentally, both my girlfriend and I have Macs, and the second laptop I used for my cousin is an old (last gen) MacBook Pro 13" with one fried RAM slot that I'm trying to get rid of. I don't think the RAM has anything to do with the problem: I've run Rome II Total War (one beefy memory-intensive game) on multiplayer before with it, and like I said I had the same issue with my gf using her laptop.

If anyone can help please let me know.
If I don't respond it means I got busy so please message me on steam that does happen occasionally.

Comments

  • EDIT; I FORGOT TO POST THAT SCREENSHOT IM A GENIUS SORRY.
  • EDIT: I have been trying this using custom maps, but once tried with a default map with the same results
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey Benjen,

    I'm suspecting one of either the copies is corrupted/outdated. I really think a fresh reinstall on *both* machines would help.

    Additionally, if you're both on the same router, you shouldn't need to join via IP - the game will show up in the server list when you click on "Join multiplayer".

    Also, have you guys tried joining through Steam? When someone is in a multiplayer lobby, you can right-click their name in your friends' list and "Join Game".
  • It does show up in the list, and its gets the same error.

    We have not tried joining through steam. Will do.

    As I said, I tried a fresh reinstall on mine but haven't had a chance to try on hers, but a fresh reinstall on both computers did not work when using both of my computers. I'll let you know if it works with a fresh reinstall and joining through steam as soon as I can try that.
Sign In or Register to comment.