Random multiplayer disconnection and reload issues

RaggedwormRaggedworm Member
edited January 14 in Multiplayer
I can play for a while as host and the game runs fine and then suddenly the other player is booted to the title screen with no warning. When we try to load again the game loads all my stuff up properly on my end and on the other end the player has all their stuff loaded properly, but I cannot see any of their Bricktrons and they cannot see mine.

Comments

  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey Raggedworm,

    - Are you both on the same version of the game? ( Check the bottom right )
    - Are you using a UGC Workshop map, or one of the official maps?
    - Are you both using wired internet connection or playing over Wi-Fi?
    - Are you joining each other via manually typing an IP address, or joining through Steam?
    - What are both of your PC specs?

    I'll need this info to begin troubleshooting the issue.

    If you're feeling particularly brave, there's a possibility that one of either your installations have corrupted or conflicting files. I'd suggest *both* of you try the steps in this article (link);

    Thanks!
  • Hello Shatojon,

    My friend and i are having the same/similair issues, we are currently playing the invasion mode coop and every now and then (somewhere between 2 secs and 2 min) the game disconnects the person joining the game.
    we are both using the most up to date version of the game 0.8.1b.2dae (17,14,21)
    We are using an original map
    we are joining each other via steam,
    specs are medium to high gaming PCs, we usually dont have any problems with other games.
    we are using discord at the same time and it doesnt disconnect from there so i doubt its network issues, we have nothing else running in the background.
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey WakVII and Raggedworm,

    Assuming you're both on Windows, can you please navigate to "C:\Users\\AppData\Local\Temp\Castle Story\Logs". If you don't know how, follow these steps;


    - Click start
    - Type "Run" and open the Run Windows application.
    - In "Open", type "%appdata%" and hit enter.
    https://streamable.com/yzfa2

    This will bring you to "AppData\Roaming" - you need to go back a level by clicking on "AppData" in your explorer's address bar.
    https://streamable.com/w5j4p

    Then click Local > Temp > Castle Story > Logs

    You will find a big list of logs that looks like this;


    Please find the one dated with the moment when you had the issues and share them to us. :) Preferably, both the person hosting and the players joining would send us their logs.

    Thank you!
Sign In or Register to comment.