Multiplayer problem

Hi. I can't connect to my friend's lobby. I have to use a VPN in order to successfully connect to him. I thought that after the latest hotfixes, we can connect to each other's lobby, however this is not the case. Is there any way we can play apart from using VPN. Port forwarding does nothing since the ISP in my country is preventing us from doing it. So we don’t want to use VPN just to play the game

There are other games that using lobby technique that we don’t find any problem connecting such as:
7 Days to Die
Dungeon Defenders 2
Payday 2
Monaco

As far as I know, 7 days to die also uses the unity engine,so I don’t think it’s an engine problem.
So is there any way we can connect to each other’s game?

Comments

  • ShatojonShatojon Administrator Developer Backer
    Hi CastleWarrior,

    Looking into this for you now, please sit tight!
  • Thanks, looking forward to hear from you.
  • ShatojonShatojon Administrator Developer Backer
    Hey CastleWarrior,

    Have you tried joining your friend (or vice versa) via Steam's friends list? Right-click your friend who is in a lobby and "Join Game" on the Steam friends' list.

    Let me know if that helps.
  • Hi shatojon,

    yeah we did, the only thing that is showing is a blank lobby with no name. we waited for 3 or more minutes and the screen remains the same.

  • ShatojonShatojon Administrator Developer Backer
    Hey CastleWarrior,

    I have the feeling there's some odd stuff going on in your filesystem for Castle Story.

    Can you please BOTH (you and your friend trying to join you) follow these steps?

    https://sauropodstudio.zendesk.com/hc/en-us/articles/218389798-How-to-do-a-fresh-reinstall-of-Castle-Story-Crashes-Crash-

    After following these steps (the important part in them is to manually delete all Castle Story files after the reinstall) - try to both play via wired connection, that means avoid Wi-Fi, plug your computers to the router/modem via Ethernet cables instead.

    I know it's a bit of a hassle, but I'm hoping it'll resolve or at least help troubleshoot the issue.

    Please let me know how it goes and sorry you've had such a hard time getting multiplayer to run!
  • Hi Shatojon,

    We've tried uninstalling the game and reinstalling the game but still we can't connect to each other's lobby. We cannot used wired connection since my laptop does not have the ethernet port. I can test using wired connection but it will have to wait until I buy external ethernet port

    Yet, before uninstalling the game, I've tried connecting using a mobile broadband which uses different ISP and I can connect to his lobby. But then using mobile broadband is not feasible due to the high cost.

    One more thing, idk may be this could help. 7 days to die used to be this way where I can't connect to my friend's server where I have to use Evolve to connect to his server. But now I can connect to his server normally when using wlan.

    Since last February or march, we cannot use Evolve effectively since we will have relay connection, not direct connection. The latency that we have is over 500ms therefore it is hard for us to play, since the lag prevent us from playing or even connecting to each other's server or lobby.
  • ShatojonShatojon Administrator Developer Backer
    Hey CastleWarrior, the fact you could connect using mobile broadband makes me think something might be wrong with your connection/Wi-Fi.

    I'm surprised your laptop doesn't have an Ethernet port, I've never heard of this. Are you sure?
  • Hi Shatojon,

    My laptop is Surface pro 2 :) , and it is quite common for 2 in 1 laptop nowadays doesn’t come with Ethernet port. However, I did bought the Ethernet adapter port, so we tried to connect to each other wired, the result is still the same.

    So I guess, there is nothing wrong with my wifi. It is actually like I mention in the beginning, it is our home broadband ISP that block us from port forwarding. Since both of us using the same ISP, unless if at least one of us using different ISP like before, that I used mobile broadband then it can connect.
  • ShatojonShatojon Administrator Developer Backer
    Hey CastleWarrior, thank you and sorry for the hassle.

    I'm escalating this with our developers to try and figure out what could be going wrong.

    Have you tried the basics? Restarting your machines, checking your firewalls, etc.. ?
  • ShatojonShatojon Administrator Developer Backer
    Hi CastleWarrior!

    One of our developers is also wondering; does your ISP put you behind a NAT? If you're not sure, could you give them a call?
  • Hi Shatojon,

    Yea we've tried everything we can like restarting pc and reinstalling Castle Story, even turning off the firewall but we still can't connect to each other server.

    About the NAT stuff, I’m not quite sure, I think so. I’ll get back to you after I get the confirmation.

    I’m so sorry, I am a bit busy right now didn’t able to reply you soon.

    Thanks for looking into this matter.
  • Hi Shatojon,

    Our ISP told us that we are behind NAT.
  • ShatojonShatojon Administrator Developer Backer
    Hey, sorry for the delay on this. I'm investigating with one of our devs, but it's not looking too good. :(
  • ShatojonShatojon Administrator Developer Backer
    Hey CastleWarrior,

    Unfortunately, behind a NAT, there's not much we can do right now to help, until we get a relay server (which is very costly).

    The only way you could play online at the moment is via a VPN (Hamachi, Evolve, etc.)

    Sorry, CastleWarrior.
  • Hi Shatojon,

    If we use hamachi or evolve, we still can’t connect to each other. Right now we can only play Castle Story if we use VPN like tunnelbear or hide.me to hide our country.

    But it is still makes us wonder, why Castle Story won’t work. I’ve tried several games with my friend and the latest game that we've tried is Castle Crashers and we can play it just fine in online multiplayer, there is no issue even if we are behind NAT.
  • DevtronDevtron Administrator
    Hi CastleWarrior,

    Are you both playing on Windows? If not can you please tell me what OS you're using?

    Thanks!
  • Just to let you know , I had some issues with the multiplayer too. The ONLY way to play was to use hamachi (wasn't working via steam). I'm on OS X and my friends are on Windows.
  • Hi Devtron,

    I'm using Windows 10 and my friend is using Windows 7
  • Hi,

    I just want to update you about the error since it's a different error from before. Maybe this will help you in figuring out the multiplayer problem that we have or may be will help you fix minor error

    1. if I connect to my friend without vpn, an error dialog appeared as shown in the image below:

    2. when we play using vpn and normally, if one of us has sudden drop with the internet connection it will disconnect the client and inform the host that the player has left. but with this new patch 0.8.1, it does not inform the host that "the player has left".

    Thanks
  • Hi I'm looking for server system in Castle Story.
  • DevtronDevtron Administrator
    Hey CastleWarrior,

    Did you get this error when trying to join via the steam 's friends list? If not could you please try again and report if it is a different error when using the "Join Game" button. I know your reported getting a blank lobby earlier when using the steam's friends list but as of 0.8.1 you should receive a more detailed error if steam fail to join the match.
  • bidiajin said:

    Hi I'm looking for server system in Castle Story.

    That sounds suggestions worthy to be honest, having "creative" sandbox servers like in Minecraft would be quite the feat and interesting IMHO. I'm more of a survival guy, but I'm not gonna lie, some of you guys build some amazing and creative structures.
  • Hi Devtron,

    We tried using Friend List and Invite method but the results are the same. Both methods produced the same error message. We don't see any additional error message other than Network Error: WrongHost.
  • DevtronDevtron Administrator
    Hey guys,

    We use Raknet for NAT punchthrough on Castle Story. Here's a small exerpt from Raknet's doc;

    "With some poor quality or homemade routers, it is possible that NAT punchthrough will not work. For example, a router that picks a new random port for each outgoing connection, and will only allow incoming connections to this port, will never work. This happens about 5% of the time."

    That may explain what's going on with you guys. The good news, is there's a fix. Once again from the exerpt;

    "To handle this case, RakNet provides the UDPProxy system. Essentially, it uses a server that you run to route messages between the source and destination client transparently. This even works to route datagrams from games not using RakNet (though you need RakNet to setup the forwarding). The combination of NATPunchthrough and UDPProxy should enable any system to connect to any other system with a 100% success rate, provided you are willing to host enough proxy servers to forward all the traffic."

    In very simple terms, there's a solution to insure 100% success rate, which is to host a relay server. This is a bit of a technical challenge for us - we're a small studio and it will cost us extra time and money budget to host a relay server (UDPProxy) - we'd like to do that and are looking into it, but it's not as easy as an on-off switch.

    The reason for punchthrough to exist is to make it so you guys don't need to forward your ports. If you can figure out how to forward the port (3000) on your router/modem setup, people should be able to connect to you via your direct IP.
Sign In or Register to comment.