IPv6

Is it possible to start a multiplayer game with IPv6? Can the other users use my IPv6 address to join my game?
My problem is, that I only get IPv6 addresses from my internet provider.

Comments

  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey angrytno1,

    Unfortunately for the time being, you can't manually enter IPv6 IPs.

    You may be able to join fine through Steam, though.
  • ChadDeanChadDean Member Backer
    Hey Shatojon!

    Its been a while since August last year.

    As the game gets more awesome with every update, I've tried to play together with a friend. We both have an IPv6 address, so unfortunately we were not able to play together. We've tried through the game and using steam to connect to each other (ohile one is waiting in the lobby). Without success.

    Any plans to make the game more IPv6 friendly in the near future? Or are there any workarounds/tipps to get multiplayer working for IPv6 users?
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey Chad,

    Can't join each other off your Steam friends' list?
  • ChadDeanChadDean Member Backer
    Hey Shatojon,

    thx for your reply!

    We've tried, but the "Join game" only opened the game and from the Steam overlay it did nothing.
    Anything special we have to look at?

    We want to try again and check if the ports are all open and correctly forwarded. I'll give feedback if we are successful or not.
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Hey Chad!

    It's a bit of a hassle, but can both you and your friend try these steps: https://sauropodstudio.zendesk.com/hc/en-us/articles/218389798-How-to-do-a-fresh-reinstall-of-Castle-Story-Crashes-Crash-

    After doing that, try joining via Steam. If it fails, please post BOTH you and your friend's multiplayer logs here. Be sure to mention who was hosting the server and who was joining as a client. https://sauropodstudio.zendesk.com/hc/en-us/articles/115001840547

    Thanks!
  • ChadDeanChadDean Member Backer
    Hey Shatojon,

    thanks again for your help. We both have created a clean install and tried to join the others game. I've also checked mit port forwarding (UPnP is also allowed on my router). Again, we were not able to play together.

    Something I've totally missed last time: I'm playing on a Mac and my fried uses a Windows10 PC. Don't know if this matters.

    Attached you'll find both brix.log files created while trying to play together.

    Thanks!
  • ShatojonShatojon Administrator Developer Backer Wiki Editor
    Thanks for the heads up Chad, I'm forwarding this to our QA to see if we can figure out what's going on.
Sign In or Register to comment.