Cant join coop 0.7 update

Hello,

I wanted to play coop with my friend, but when i tried to join i get a clientdisconnectedonself error.

Next try, i join with steam. nothing happens and my friend says his name has been removed from the lobby. And i cant see the main menu buttons anymore so had to alt-f4 to quit.

When my friend has started playing a match, i tried to join the match and my friends match suddenly quits on its own and gives this clientdisconnectedonself error again -_-.

The same happens when i host the game. and when i leave i get the (you guessed it) clientdisconnectedonself error.

I hope you guys have already received bug reports. because this is making me sick!

Comments

  • MiniMackeroniMiniMackeroni Member
    edited July 2016
    I'm having the same problem. Neither my friend or myself can connect to each other using either Steam (which makes the host disappear from the lobby) or through direct IP (which just does nothing, an endless Joining Game...).

    I also get the error message that Primelock describes: clientdisconnectedonself error when leaving the my own server.
  • ShatojonShatojon Administrator Developer Backer
    Hey guys!

    Sorry to hear you're having a hard time with the game.

    Lets start with the basic trouble shooting;

    1- Try restarting the game.
    2- Try switching which person is hosting.

    If that doesn't work, let us know here.

    Keep in mind certain things; you can not (yet) join through Steam. The lobby will only display servers that are on the same network as you (Same router/wifi). Otherwise, you have to use the custom address and enter their IP address.

    Thank you.
  • MiniMackeroniMiniMackeroni Member
    edited July 2016
    Edit: Hi, Shatojon!

    Both of those didn't work for me and my friend. We had already tried connecting to each others IP, but we both get stuck trying to join the game with the only option to cancel the joining and start over at the main menu.

    We also tried opening a port through the router and firewall (port 3000 in this case) and then joining the IP and using the port 3000. But that doesn't seem to work either.
  • ShatojonShatojon Administrator Developer Backer
    Sorry to hear that, Mini.

    Lets get this out of the way and make sure you're both on the right version. Can you both please attempt the steps in this article? https://sauropodstudio.zendesk.com/hc/en-us/articles/218389798-How-to-do-a-fresh-reinstall-of-Castle-Story-Crashes-Crash-

    Thank you.
  • Hey, thanks for the response.

    Sorry to say, it didn't yield results. I uninstalled it from Steam, deleted the folder and searched for any leftovers. My friend took a different route and installed the game on a fresh new laptop with no prior install of the game. Whoever tries to connect to the other player hosting still gets stuck on an infinite "Trying to join". Firewall is also disabled in this case.

    The simplest solution would be to download a VPN network program, as playing on LAN would probably not be a problem. But I'm guessing we're both kind of curious on what's causing this by now.
  • Yeah, thanks for the response.

    But to me it also doesnt work. I hope this gets fixed next update, because this is worse than on the previous version.
  • ShatojonShatojon Administrator Developer Backer
    Hey guys, not ideal, but check the reply posted here. Hopefully something in there might help out?

    http://steamcommunity.com/app/227860/discussions/0/365172547945560739/#c365172547952827649

    It's very hard to troubleshoot that issue because we can't reproduce it, but usually speaking, if you get disconnected or get freezes, it's because one of the playing parties is having issues with their internet connections, dropped packets, etc.
  • ShatojonShatojon Administrator Developer Backer
    Hey guys,

    Just a little update; part of the next patch (0.7.1) will improve on an issue that we discovered causing players to be disconnected when they shouldn't be. Hopefully this will fix the issue you're experiencing in this thread.

    Update us if it doesn't when the patch comes out!
  • PrimelockPrimelock Member
    edited July 2016
    Good to hear.

    When is the update due, because development goes pretty slow down there isn't it?
  • PrimelockPrimelock Member
    edited July 2016
    Ow nevermind, its already updated ^^.
  • Well, me and my friend can finally join and play together.

    Good job guys!.
  • ShatojonShatojon Administrator Developer Backer
    That's really awesome to hear, Primelock. :smiley:
  • Oh one thing to add, when i leave from lobby i still receive this clientDisconnectOnSelf error.

    But this is just a small issue.
  • ShatojonShatojon Administrator Developer Backer
    Ahh thank you for pointing that out. :)
  • MiniMackeroniMiniMackeroni Member
    edited July 2016
    Bad news, Shatojon. The update doesn't seem to have helped me and my friend. We still have the same issue where we can never join each other. After a while (10-15 seconds?) we get disconnected. Pictures below.

    http://puu.sh/q4K2O/b2641edb32.jpg

    http://puu.sh/q4K4i/541b14879a.jpg

    One strange bug from this is also that the main menu becomes completely empty. You only see the background. O.o (Thread starter also had this)

    Edit: Seems like my buddy is giving up for now. Maybe when steam multiplayer gets integrated.
  • Shatojon. Seems like we solved it, somehow. Seems like.. Castle Story doesn't like when you copy the IP from Steam Chat. Apparently you can't copy the text from somewhere else. When we typed it in, number for number, it worked.

    What.
  • ShatojonShatojon Administrator Developer Backer
    Oh wow, I'm glad it's fixed and thank you for sharing your solution, it might be helpful for others!
  • MiniMackeroniMiniMackeroni Member
    edited July 2016
    I could have sworn I did type it out once though, in 0.7. I'm guessing we had the same problem as Primelock, which was fixed in the latest version, but also that we didn't try typing it in 0.7.1, so we thought the problem wasn't solved. But now it works! Yay!
  • I should add this for those still with problems.

    When we retry after the update we still had the issue. But after checking port forward settings, it seemed i've setup the port wrongly. After fixing the port forwarding settings it finally worked.
Sign In or Register to comment.